Xfce Wiki

Sub domains
 

Site Tools


Quicklauncher

About

The goal of the xfce4-quicklauncher-plugin is double.

  • First, it is intented to offer you a fast and easy way to configure the plugins wich are on your panel.
  • Secondly, it is able to display these launchers on one or more lines, and they are displayed so that they don't waste space. They also feature a little zoom effect when you pass the mouse over them.

Screenshots

The menu plugin with some launchers near him
:projects:panel-plugins:xfce4-quicklauncher-plugin-mini.png

a screenshot of the xfce4 panel with the quicklauncher plugin, and it's config dialog
:projects:panel-plugins:xfce4-quicklauncher-plugin.png

Another one with a quicklauncher on the left to launch applications and one on the rignt to lock / shutdown the computer
:projects:panel-plugins:xfce4-quickelauncher-launch_and_quit.png?240

Usage

This Plugin is quite easy to use.
After having added him to your panel, click on the “properties” button. The config dialog will then be prompted. Once here, all you have to do is to enter the command you wanna use and to choose the icon by double clicking on them. * Note: When you double click, you have first the choice between some stocked icons. (the same as with normal panel launchers). But you can also use your own icon by clicking on the last button.
:projects:panel-plugins:quicklauncher-choose-icon.png

Releases

xfce4.2

These realease are made in order to work with the current stable release of xfce. The latest one is 0.81.
xfce4-quicklauncher-plugin-0.81.tar.gz

xfce4.4

These realease are made in order to work with the develloppement version of xfce, and with the future 4.4 version of him.
The latest version is 1.9.1. This is quite the same as the 0.81 one, except that it require the develloppement version of the panel, and allow you to have more than one quicklauncher at a time.
xfce4-quicklauncher-plugin-1.9.2.tar.bz2

Requirements

No extra-dependencies. I you have the xfce4-panel working, then you already have all that you need.

Changelog

version 1.92:

replace g_assert by g_return_if_fail in order to not crash the panel.
removed the use of eventboxes. Looks better when a theme is used.
hopefully fix some compilation problems with netbsd
lot of new translations (thanks to the people working on this)

version 1.91:

make dist now works
fix translations + new ones (thanks to Daichi)
fix a bug who makes the panel size grown when the quicklauncher plugin was added
fix multiple warnings
fix a little bug who crashed the panel
fix what seems to be a bug with gcc4
remove useless vars
fix a warning when removing a launcher.

version 1.90:

updated source code but also auto tools files in order to work with the 4.4 version of the panel
allow multiple instance

version 0.82:

minor bug fix
enhenced preview window in the filechooser

version 0.81:

fix a compilation problem with gcc4
fix gettext stuff (thanks Jasper ;) )

version 0.8:

add french translation (not tested)
FIX: size of zoomed icons is now calculated from icons size instead of panel size
some little changes
FIX: some images wasn't unloaded when destroying a launcher.
add tooltip

Version 0.7:

FIX: a problem with icon size when loading
FIX: there was a crash sometimes when clicking on an icon.
some internal changes
make icons bigger when passing throught
change icon when clicking on
Change: use GdkPixbuf and event_boxes instead of buttons. Looks better ; ).

Version 0.6:

FIX: Icon size in the configuration dialog doesn't take care of the size of the icons in the bar anymore
Add: number of lines is now configurable
FIX: Size of the icons are now better handled
FIX: some possible memory leaks
some internal changes.

Version 0.5:

First public release

projects/panel-plugins/xfce4-quicklauncher-plugin.txt · Last modified: 2007/11/09 03:50 (external edit)